Head End Replication

Cumulus Networks Layer-3 Leaf-Spine Fabric with EVPN as a Control Plane for VXLAN

September 26, 2017
Testing Cumulus Networks Linux
by Pablo Narváez

Welcome back! In this article I will be testing VXLAN again, but this time on Cumulus Linux. I will replace the manual VTEP flood-lists/mappings (Head End Replication) with EVPN to provide a different control plane for VXLAN.

For lab purposes, I will use a self-contained virtual environment to run Cumulus VX as a VM on top of Ubuntu 16.0.4 LTS and KVM. This is the same environment I’ve used in the past to run other network operating systems like Arista vEOS and Free Range Routing (FRR).

The Cumulus-VX Fabric will be an independent POD for now, but in a following post I will connect this POD to the FRR block so we can have a single routed virtual environment.

NETWORK DISAGGREGATION

Network disaggregation means to separate the network into its component parts. Actually, network disaggregation implies the ability to source switching hardware and network operating systems separately. We have been doing this for years now in the server space, buying a server from any manufacturer and then loading an OS of your choice.

In this context, Cumulus Linux is an open network operating system that allows you to automate, customize and scale the network. From the networking perspective, Cumulus Linux is just the NOS, so you still need an OCP-certified white-box switch to run it. Different vendors offer bright-box switches like HPE, DELL and Edgecore Networks; they all use merchant silicon ASICs, so the actual difference when selecting a hardware vendor is their software ecosystem.

CUMULUS VX OVERVIEW

Cumulus VX is not a production-ready network operating system. It has the same foundation as Cumulus Linux, including all the control plane elements, but without an actual ASIC for line rate performance or hardware acceleration.

NOTE: You can see the similarities and differences between Cumulus VX and Cumulus Linux in the product comparison table posted here.

Cumulus VX is a free virtual environment to test Cumulus Networks within your own environment. It runs in a virtual machine (VM) on a standard x86 server. The VM is a 64-bit operating system running Debian Linux Jessie 4.1, using virtio drivers for network and HDD interfaces as well as the logical volume manager (LVM).

Cumulus VX integrates with the following hypervisors:

  • VMware
    • vSphere – ESXi 5.5
    • VMware Fusion
    • VMware Workstation
  • VirtualBox
  • KVM

INSTALLING CUMULUS VX

Installing Cumulus VX involves downloading and installing the preferred hypervisor platform/development environment and downloading the relevant Cumulus VX image from the Cumulus website. Once these are downloaded, the VX image can be imported to create the necessary VMs.

Cumulus VX images for all supported platforms are available from the Cumulus Networks website.

Each disk image contains a single VM for a standalone switch. The image can be cloned to build the test network.

To provision the VMs, you can use the hypervisor wizard/deployment tools. For KVM/QEMU, I’m going to use virt-manager  but you can also use virsh.

If you need help with the VM deployment on KVM, please check my previous posts.

This section assumes that a two-leaf / two-spine network topology is being configured. Once the base VMs are ready, you need to configure the network interfaces and routing.

The drawing below shows where each network adapter (vNIC) is, what network it’s configured for, and how the VMs are interconnected. Every connection between two adapters represents an isolated segment which must be configured as a virtual network in KVM.

To ensure that every link is isolated, we need to configure each virtual network with an exclusive name (I configured them as “net-x”) and use every virtual network only once for a unique link. The links between each VM will act like physical cables.

cumulus-vx connectivy diagram

Cumulus-VX Connectivy Diagram

NOTE: For KVM, Cumulus suggests to use the virtio driver for the network adapters.

Accessing Cumulus VX

It’s time to log into the Cumulus VMs. Use the following credentials to access the CLI (NCLU):

User name: cumulus
Password: CumulusLinux!

You can change the default password with the following command:

cumulus@switch$ passwd cumulus

Also, we need to name our switch. To change the hostname, run net add hostname which modifies both the /etc/hostname and /etc /hosts files with the desired hostname.

cumulus@switch$net add hostname spine01
cumulus@switch:~$ net pending
cumulus@switch:~$ net commit

NOTE: The command prompt in the terminal doesn’t reflect the new hostname until you either log out of the switch or start a new shell.

From the commands above, notice that you have to commit any changes made to the configuration:

cumulus@switch:~$ net pending
cumulus@switch:~$ net commit

The net pending command helps you verify the changes before applying them.

Once the changes are saved, the current (active) configuration is displayed with the  following command:

cumulus@spine01$ net show configuration

Out-of-Band Management (OOB)

Switches supported in Cumulus Linux always contain at least one dedicated Ethernet management port, which is named eth0. This interface is geared specifically for out-of-band management use. The management interface uses DHCPv4 for addressing by default. You can set a static IP address with the Network Command Line Utility (NCLU).

cumulus@spine01$ net add interface eth0 ip add 10.0.0.33/24
cumulus@spine01$ net add interface eth0 alias oob-mgmt
cumulus@spine01:~$ net pending
cumulus@spine01:~$ net commit

You can use a management VRF (Virtual Routing and Forwarding) to isolate the management network and make it inaccessible outside its subnet (unless you explicitly allow it).

cumulus@spine01$ net add vrf mgmt

Once you commit the command, your current session will close; when relogin, the mgmt-vrf will be active and shown as part of the command prompt:

cumulus@spine01:mgmt-vrf:~$ 

LAYER-2 CONFIGURATION

The Cumulus Linux bridge driver supports two configuration modes, one that is VLAN-aware, and one that follows a more traditional Linux bridge model.

The VLAN-aware mode in Cumulus Linux implements a configuration model with one single instance of Spanning Tree. Each physical bridge member port is configured with the list of allowed VLANs as well as its port VLAN ID. This significantly reduces the configuration size, and eliminates the large overhead of managing the port/VLAN instances as subinterfaces.

As shown in the the diagram posted aboveserver07 and server08 will belong to the same VLAN/network subnet. Please notice you do not need to activate the network ports, just start configuring the parameters and the switch ports will be brought up.

#Leaf01
 cumulus@leaf01:mgmt-vrf:~$ net add bridge bridge ports swp1
 cumulus@leaf01:mgmt-vrf:~$ net add bridge alias layer2_bridge
 cumulus@leaf01:mgmt-vrf:~$ net add interface swp1 bridge access 14
 cumulus@leaf01:mgmt-vrf:~$ net add bridge  bridge-vlan-aware yes
 cumulus@leaf01:mgmt-vrf:~$ net pending
 cumulus@leaf01:mgmt-vrf:~$ net commit
#Leaf02
cumulus@leaf02:mgmt-vrf:~$ net add bridge bridge ports swp1
cumulus@leaf02:mgmt-vrf:~$ net add bridge alias layer2_bridge
cumulus@leaf02:mgmt-vrf:~$ net add interface swp1 bridge access 14
cumulus@leaf02:mgmt-vrf:~$ net add bridge  bridge-vlan-aware yes
cumulus@leaf02:mgmt-vrf:~$ net pending
cumulus@leaf02:mgmt-vrf:~$ net commit

 NOTE: To identify the name and select the switch ports, you can use the Tab key to display the options.

As in any Linux distro, you can verify the VLAN configuration with the “bridge” command.

cumulus@leaf01:mgmt-vrf:~$ net show bridge vlan

Interface      VLAN  Flags
-----------  ------  ---------------------
swp1             14  PVID, Egress Untagged

cumulus@leaf01:mgmt-vrf:~$

Link Layer Discovery Protocol – LLDP

Before configuring Layer-2 services and the Layer-3 routed interfaces between VMs, you can use LLDP (Link Layer Discovery Protocol) to verify the network assignments for each VM.

LLDP allows you to know which ports are neighbors of a given port. By default, lldpd runs as a daemon and is started at system boot.

To see all neighbors on all ports/interfaces use the following command:

cumulus@leaf01:mgmt-vrf:~$ sudo lldpcli show neighbors
-------------------------------------------------------------------------------
LLDP neighbors:
-------------------------------------------------------------------------------
Interface: eth0, via: LLDP, RID: 1, Time: 5 days, 00:36:44
 Chassis: 
 ChassisID: mac 52:54:00:2a:f8:29
 SysName: leaf02
 SysDescr: Cumulus Linux version 3.4.0 running on QEMU Standard PC (i440FX + PIIX, 1996)
 TTL: 120
 MgmtIP: 10.0.0.25
 MgmtIP: fe80::5054:ff:fe2a:f829
 Capability: Bridge, on
 Capability: Router, on
 Port: 
 PortID: ifname eth0
 PortDescr: oob-mgmt
-------------------------------------------------------------------------------
Interface: eth0, via: LLDP, RID: 2, Time: 5 days, 00:36:36
 Chassis: 
 ChassisID: mac 52:54:00:20:8e:8a
 SysName: leaf03
 SysDescr: Arista Networks EOS version 4.17.5M running on an Arista Networks vEOS
 TTL: 120
 MgmtIP: 10.0.1.23
 Capability: Bridge, on
 Capability: Router, on
 Port: 
 PortID: ifname Management1
 PortDescr: oob-mgmt
-------------------------------------------------------------------------------
Interface: swp2, via: LLDP, RID: 5, Time: 5 days, 00:36:30
 Chassis: 
 ChassisID: mac 52:54:00:ed:c2:a7
 SysName: spine01
 SysDescr: Cumulus Linux version 3.4.0 running on QEMU Standard PC (i440FX + PIIX, 1996)
 TTL: 120
 MgmtIP: 10.0.0.33
 MgmtIP: fe80::5054:ff:feed:c2a7
 Capability: Bridge, off
 Capability: Router, on
 Port: 
 PortID: ifname swp1
 PortDescr: link_to_leaf01-swp2
-------------------------------------------------------------------------------
Interface: swp3, via: LLDP, RID: 6, Time: 5 days, 00:36:30
 Chassis: 
 ChassisID: mac 52:54:00:40:5f:b1
 SysName: spine02
 SysDescr: Cumulus Linux version 3.4.0 running on QEMU Standard PC (i440FX + PIIX, 1996)
 TTL: 120
 MgmtIP: 10.0.0.34
 MgmtIP: fe80::5054:ff:fe40:5fb1
 Capability: Bridge, off
 Capability: Router, on
 Port: 
 PortID: ifname swp1
 PortDescr: link_to_leaf01-swp3
-------------------------------------------------------------------------------
cumulus@leaf01:mgmt-vrf:~$

LAYER-3 CONFIGURATION

Configuring the SVIs (Switch VLAN Interfaces)

Bridges can be included as part of a routing topology after being assigned an IP address. This enables hosts within the bridge to communicate with other hosts outside of the bridge, via a switch VLAN interface (SVI), which provides layer 3 routing.

#Leaf01
cumulus@leaf01:mgmt-vrf:~$ net add vlan 100 ip address 192.168.14.1/24
cumulus@leaf01:mgmt-vrf:~$ net pending
cumulus@leaf01:mgmt-vrf:~$ net commit|
#Leaf02
cumulus@leaf02:mgmt-vrf:~$ net add vlan 100 ip address 192.168.14.1/24
cumulus@leaf02:mgmt-vrf:~$ net pending
cumulus@leaf02:mgmt-vrf:~$ net commit|

The VLAN SVIs will work as the server gateways on the Leaf switches. To validate the SVI functionality, try pinging from each server to its local gateway.

Also, verify that the server MAC address are added to the local MAC table on each switch:

#Leaf01
cumulus@leaf01:mgmt-vrf:~$ sudo arp -a
? (172.16.1.1) at 52:54:00:af:ae:18 [ether] on swp2
? (192.168.14.11) at 52:54:00:e8:a7:59 [ether] on vlan14
? (172.16.1.5) at 52:54:00:55:09:19 [ether] on swp3
? (10.0.0.1) at fe:54:00:00:d4:96 [ether] on eth0
cumulus@leaf01:mgmt-vrf:~$
#Leaf02
cumulus@leaf02:mgmt-vrf:~$ sudo arp -a
? (172.16.1.9) at 52:54:00:cb:11:f9 [ether] on swp2
? (10.0.0.1) at fe:54:00:00:d4:96 [ether] on eth0
? (172.16.1.13) at 52:54:00:33:db:3c [ether] on swp3
? (192.168.14.12) at 52:54:00:60:ad:92 [ether] on vlan14

Leaf-Spine Interconnects

All Leaf switches are directly connected to all spine switches. In a L3LS topology all of these interconnections are routed links. These routed interconnects can be designed as point-to-point links or as port channels. For production environments, there are pros and cons to each design, Leaf-Spine interconnects require careful consideration to ensure uplinks are not over-subscribed. Point-to-point routed links will be the focus of this guide.

Layer-3 Network Diagram

Layer-3 Network Diagram

As you can see, each Leaf has a point- to-point network between itself and each Spine. In real-life environments, you need to strike the right balance between address conservation and leaving room for the unknown. Using a /31 mask will work as will a /30, the decision will depend on your personal circumstances.

Check the configuration for Spine01, then you can configure the remaining switches as described in the diagram above.

#Spine01
cumulus@spine01:mgmt-vrf:~$ net add int swp1 ip address 172.16.1.1/30
cumulus@spine01:mgmt-vrf:~$ net add int swp1 alias link_to_leaf01-swp2
cumulus@spine01:mgmt-vrf:~$ net add int swp2 ip address 172.16.1.9/30
cumulus@spine01:mgmt-vrf:~$ net add int swp2 alias link_to_leaf02-swp2
cumulus@spine01:mgmt-vrf:~$ net commit

BORDER GATEWAY PROTOCOL (BGP)

BGP is the routing protocol that runs the Internet. It is an increasingly popular protocol for use in the data center as it lends itself well to the rich interconnections in a CLOS topology.

ECMP with BGP

If a BGP node hears a prefix p from multiple peers, it has all the information necessary to program the routing table to forward traffic for that prefix p through all of these peers. Thus, BGP supports equal-cost multipathing (ECMP).

In order to perform ECMP in BGP, you may need to configure net add bgp bestpath as-path multipath-relax (if you’re using eBGP).

In Cumulus Linux, the BGP maximum-paths setting is enabled by default, so multiple routes are already installed. The default setting is 64 paths.

eBGP vs. iBGP

There are number of reasons to choose eBGP but one of the more compelling reasons is simplicity, particularly when configuring load sharing (via ECMP) which is one of the main design goals of the L3LS. Using eBGP ensures all routes/paths are utilized with the least amount of complexity and fewest steps to configure.

I’ve tested both options and my personal choice is eBGP even on production environments. Although an iBGP implementation is technically feasible using eBGP allows for a simpler less complex design that is easier to troubleshoot.

BGP Autonomous System Number (ASN)

BGP supports several designs when assigning Autonomous System Numbers (ASN) in a L3LS topology. For this lab, the Common Spine ASN – Discrete Leaf ASN design will be used.

This design uses a single ASN for all spine nodes and discrete ASNs for each leaf nodes. Some benefits of this design are:

  • Each rack can now be identified by its ASN
  • Traceroute and bgp commands will show discrete AS making troubleshooting easier
  • Uses inherent BGP loop prevention
  • Unique AS numbers help troubleshooting and don’t require flexing the EBGP path selection algorithm

As an alternative, you can use the Common Spine ASN – Common Leaf ASN design where a common (shared) ASN will be assigned to the Spine nodes and another ASN to the Leaf nodes.

BGP Configuration

Leaf and Spine switches are interconnected with Layer-3 point-to-point links, and every Leaf is connected to all Spines with at least one interface. Also, there’s no direct dependency or interconnection between Spine switches. All the Leaf nodes can send traffic evenly towards the Spine through the use of Equal Cost Multi Path (ECMP) which is inherent to the use of routing technologies in the design.

NOTE: We have just two Spine switches in our lab, but you can add additional nodes on demand. It’s not required to have an even number of Spine switches, just make sure to have at least one link from each Leaf to every Spine.

Note that all spine switches share a common ASN while each Leaf has a different ASN, see the BGP diagram below for details.

BGP ASN Scheme

BGP ASN Scheme

For Cumulus Linux 3.4 and later releases, the routing control plane (including EVPN) is installed as part of the Free Range Routing (FRR) package, rather than the Quagga package. For more information regarding FRR, refer to the following links:

FRRouting does not start by default in Cumulus Linux. Before you run FRRouting, make sure you have enabled the relevant daemons that you intend to use.

Edit the /etc/frr/daemons file and enable the daemons.

cumulus@spine01:mgmt-vrf:~$ sudo cat /etc/frr/daemons
# This file tells the frr package which daemons to start.
#
.....
#
zebra=yes
bgpd=yes
ospfd=yes
ospf6d=no
ripd=no
ripngd=no
isisd=no
pimd=no
ldpd=no
nhrpd=no
eigrpd=no
babeld=no
.....
#
cumulus@spine01:mgmt-vrf:~$

You will also need to enable the FRR service. Please check the procedure in the configuration guide posted here.

Once FRR is active, you can proceed with the BGP configuration. First, identify each BGP node (switch) by assigning an ASN and router-id according to the following list:

leaf01 r-id:10.0.1.24 /32
leaf02 r-id:10.0.1.25 /32
spine01 r-id:10.0.1.13 /32
spine02 r-id:10.0.1.14 /32

#spine01
cumulus@spine01:mgmt-vrf:~$ net add bgp autonomous-system 65030
cumulus@spine01:mgmt-vrf:~$ net add bgp router-id 10.0.1.13
#spine02
cumulus@spine02:mgmt-vrf:~$ net add bgp autonomous-system 65030
cumulus@spine02:mgmt-vrf:~$ net add bgp router-id 10.0.1.14
#leaf01
cumulus@leaf01:mgmt-vrf:~$ net add bgp autonomous-system 65031
cumulus@leaf01:mgmt-vrf:~$ net add bgp router-id 10.0.1.24
#leaf02
cumulus@leaf02:mgmt-vrf:~$ net add bgp autonomous-system 65032
cumulus@leaf02:mgmt-vrf:~$ net add bgp router-id 10.0.1.25

 NOTE: Notice that you don’t have to configure a loopback interface to assign the router-id. In fact, Cumulux Linux has a default loopback interface (lo) which needs to be there just for system usage (127.0.0.1).

Next. specify to whom it must disseminate routing information by configuring the BGP neighbors and what prefixes are originated from each switch.

#spine01
cumulus@spine01:mgmt-vrf:~$ net add bgp neighbor 172.16.1.2 remote-as 65031
cumulus@spine01:mgmt-vrf:~$ net add bgp neighbor 172.16.1.10 remote-as 65032
cumulus@spine01:mgmt-vrf:~$ net add bgp ipv4 unicast network 10.0.1.13/32
cumulus@spine01:mgmt-vrf:~$ net commit
#spine02
cumulus@spine02:mgmt-vrf:~$ net add bgp neighbor 172.16.1.6 remote-as 65031
cumulus@spine02:mgmt-vrf:~$ net add bgp neighbor 172.16.1.14 remote-as 65032
cumulus@spine02:mgmt-vrf:~$ net add bgp ipv4 unicast network 10.0.1.14/32
cumulus@spine02:mgmt-vrf:~$ net commit
#leaf01
cumulus@leaf01:mgmt-vrf:~$ net add bgp neighbor 172.16.1.1 remote-as 65030
cumulus@leaf01:mgmt-vrf:~$ net add bgp neighbor 172.16.1.5 remote-as 65030
cumulus@leaf01:mgmt-vrf:~$ net add bgp ipv4 unicast network 10.0.1.24/32
cumulus@leaf01:mgmt-vrf:~$ net add bgp redistribute connected
cumulus@leaf01:mgmt-vrf:~$ net commit
#leaf02
cumulus@leaf02:mgmt-vrf:~$ net add bgp neighbor 172.16.1.9 remote-as 65030
cumulus@leaf02:mgmt-vrf:~$ net add bgp neighbor 172.16.1.13 remote-as 65000
cumulus@leaf02:mgmt-vrf:~$ net add bgp ipv4 unicast network 10.0.1.25/32
cumulus@leaf02:mgmt-vrf:~$ net add bgp redistribute connected
cumulus@leaf02:mgmt-vrf:~$ net commit

BGP Verification

You can verify the BGP operation by running the following commands:

  • net show bgp summary
  • net show bgp neighbors

The state for all neighbors should be ESTABLISHED.

cumulus@spine01:mgmt-vrf:~$ net show bgp summary

show bgp ipv4 unicast summary
=============================
BGP router identifier 10.0.1.13, local AS number 65030 vrf-id 0
BGP table version 27
RIB entries 15, using 2160 bytes of memory
Peers 2, using 41 KiB of memory

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
leaf01(172.16.1.2) 4 65031 21014 21012 0 0 0 17:27:05 4
leaf02(172.16.1.10) 4 65032 21013 21011 0 0 0 17:27:05 4

Total number of neighbors 2

show bgp ipv6 unicast summary
=============================

show bgp l2vpn evpn summary
===========================
BGP router identifier 10.0.1.13, local AS number 65030 vrf-id 0
BGP table version 0
RIB entries 3, using 432 bytes of memory
Peers 2, using 41 KiB of memory

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
leaf01(172.16.1.2) 4 65031 21014 21012 0 0 0 17:27:05 3
leaf02(172.16.1.10) 4 65032 21013 21011 0 0 0 17:27:05 3

Total number of neighbors 2
cumulus@spine01:mgmt-vrf:~$

VIRTUAL EXTENSIBLE LAN – VXLAN ROUTING

VXLAN routing, sometimes referred to as inter-VXLAN routing, provides IP routing between VXLAN VNIs in overlay networks. The routing of traffic is based on the inner header or the overlay tenant IP address.

NOTE: Cumulus Linux includes native Linux VXLAN kernel support.

When configuring VXLAN in Cumulus Linux, we need a souce IP for the each VTEP which is usually associated to a loopback interface.

For this lab, I will add a new switch port (swp4) and configure it as a loopback interface.

To configure one or more switch ports for loopback mode, edit the /etc/cumulus/ports.conf file, changing the port speed to loopback. In the example below, swp4 is configured for loopback mode:

cumulus@leaf01:mgmt-vrf:~$ sudo nano /etc/cumulus/ports.conf 
 ... 
 4=loopback 
 ...

After saving the ports.conf file, you must restart switchd for the changes to take effect.

cumulus@leaf01:mgmt-vrf:~$ sudo systemctl restart switchd

Configure the IP address for swp4 which is to be used as the VXLAN source IP for the VTEP on Leaf switches.

# leaf01
cumulus@leaf01:mgmt-vrf:~$ net add interface swp4 ip address 10.0.3.1/32
cumulus@leaf01:mgmt-vrf:~$ net commit
# leaf02
cumulus@leaf02:mgmt-vrf:~$ net add interface swp4 ip address 10.0.3.2/32
cumulus@leaf02:mgmt-vrf:~$ net commit

Now we have to advertise the swp4 IP addresses into BGP so the VTEPs are reachable across the fabric. If you already have the “redistribute connected” command on the Leaf switches, you don’t need to add the network statement in the BGP configuration.

Verify that the VTEPs are reachable across the Datacenter fabric.

cumulus@spine01:mgmt-vrf:~$ net show route

show ip route
=============
Codes: K - kernel route, C - connected, S - static, R - RIP,
 O - OSPF, I - IS-IS, B - BGP, P - PIM, E - EIGRP, N - NHRP,
 T - Table, v - VNC, V - VNC-Direct, A - Babel,
 > - selected route, * - FIB route

B>* 10.0.3.1/32 [20/0] via 172.16.1.2, swp1, 17:28:01
B>* 10.0.3.2/32 [20/0] via 172.16.1.10, swp2, 17:28:01
C>* 172.16.1.0/30 is directly connected, swp1
B>* 172.16.1.4/30 [20/0] via 172.16.1.2, swp1, 17:28:01
C>* 172.16.1.8/30 is directly connected, swp2
B>* 172.16.1.12/30 [20/0] via 172.16.1.10, swp2, 17:28:01
B>* 192.168.14.0/24 [20/0] via 172.16.1.2, swp1, 17:28:01

show ipv6 route
===============
Codes: K - kernel route, C - connected, S - static, R - RIPng,
 O - OSPFv3, I - IS-IS, B - BGP, N - NHRP, T - Table,
 v - VNC, V - VNC-Direct, A - Babel,
 > - selected route, * - FIB route

C * fe80::/64 is directly connected, swp1
C>* fe80::/64 is directly connected, swp2
cumulus@spine01:mgmt-vrf:~$

When the BGP configuration is ready and the VTEPs can ping each other, it’s time to configure VXLAN.

We need to associate and map the VXLAN VNIs to the server (access) VLANs. There’s a single VLAN so we just need a single VLAN-to_VNI mapping.

#Leaf01
cumulus@leaf01:mgmt-vrf:~$ net add vxlan vni-1014 vxlan id 1014
cumulus@leaf01:mgmt-vrf:~$ net add vxlan vni-1014 bridge access 14
cumulus@leaf01:mgmt-vrf:~$ net add vxlan vni-1014 vxlan local-tunnelip 10.0.3.1
cumulus@leaf01:mgmt-vrf:~$ net add vxlan vni-1014 mtu 9152
 #Leaf02
 cumulus@leaf02:mgmt-vrf:~$ net add vxlan vni-1014 vxlan id 1014
 cumulus@leaf02:mgmt-vrf:~$ net add vxlan vni-1014 bridge access 14
 cumulus@leaf02:mgmt-vrf:~$ net add vxlan vni-1014 vxlan local-tunnelip 10.0.3.2
 cumulus@leaf02:mgmt-vrf:~$ net add vxlan vni-1014 mtu 9152

ETHERNET VIRTUAL PRIVATE NETWORK – EVPN

Ethernet Virtual Private Network (EVPN) provides a control plane for VXLANs in Cumulus Linux, with the following functionality:

  • VNI membership exchange between VTEPs using EVPN type-3 routes
  • Exchange of host MAC and IP addresses using EVPN type-2 (MAC/IP advertisement) routes
  • Support for host/VM mobility (MAC and IP moves) through exchange of the MAC Mobility Extended community
  • Support for ARP/ND suppression, which provides VTEPs with the ability to suppress ARP flooding over VXLAN tunnels
  • Support for distributed asymmetric routing between different subnets

EVPN is not the only option to provide a control plane for VXLAN. Several options are available like configuring manual VTEP flood-lists to replicate the BUM between VTEPs (known as HER – Head End Replication), you can also integrate an SDN controller to synchronize and coordinate the VTEPs, or a multicast-based approach can be implemented (not really recommended for the implications to enable multicast in the Datacenter devices and the scalability limitations).

 Enabling EVPN between BGP Neighbors

You enable EVPN between BGP neighbors by adding the address family evpn to the existing neighbor address-family activation command.

For a non-VTEP device, such as a Spine switch, that is merely participating in EVPN route exchange, activating the neighbors for the EVPN address family is the only configuration needed.

#Spine01
cumulus@spine01:mgmt-vrf:~$ net add bgp evpn neighbor 172.16.1.2 activate
cumulus@spine01:mgmt-vrf:~$ net add bgp evpn neighbor 172.16.1.10 activate
cumulus@spine01:mgmt-vrf:~$ net commit
#Spine02
cumulus@spine02:mgmt-vrf:~$ net add bgp evpn neighbor 172.16.1.6 activate
cumulus@spine02:mgmt-vrf:~$ net add bgp evpn neighbor 172.16.1.14 activate
cumulus@spine02:mgmt-vrf:~$ net commit
#Leaf01
cumulus@leaf01:mgmt-vrf:~$ net add bgp evpn neighbor 172.16.1.1 activate
cumulus@leaf01:mgmt-vrf:~$ net add bgp evpn neighbor 172.16.1.5 activate
cumulus@leaf01:mgmt-vrf:~$ net commit
#Leaf02
cumulus@leaf02:mgmt-vrf:~$ net add bgp evpn neighbor 172.16.1.9 activate
cumulus@leaf02:mgmt-vrf:~$ net add bgp evpn neighbor 172.16.1.13 activate
cumulus@leaf02:mgmt-vrf:~$ net commit

The above configuration does not result in BGP knowing about the local VNIs defined on the system and advertising them to peers.

Advertising All VNIs

A single configuration variable enables the BGP control plane for all VNIs configured on the switch. Set the variable “advertise-all-vni” to provision all locally configured VNIs to be advertised by the BGP control plane. FRR is not aware of any local VNIs and MACs associated with that VNI until advertise-all-vni is configured.

When a local VNI is learned by FRR and there is no explicit configuration for that VNI in FRR, the route distinguisher (RD) and import and export route targets (RTs) for this VNI are automatically derived — the RD uses “RouterId:VNI-Index” and both RTs use “AS:VNI”. The RD and RTs are used in the EVPN route exchange, with the former to disambiguate EVPN routes in different VNIs (as they may have the same MAC and/or IP address) while the latter describes the VPN membership for the route.

To build upon the previous example, run the following commands to advertise all VNIs.

#Leaf01cumulus@leaf01:mgmt-vrf:~$ net add bgp evpn neighbor 172.16.1.1 activate
cumulus@leaf01:mgmt-vrf:~$ net add bgp evpn neighbor 172.16.1.5 activate
cumulus@leaf01:mgmt-vrf:~$ net add bgp evpn advertise-all-vni
cumulus@leaf01:mgmt-vrf:~$ net commit
#Leaf02cumulus@leaf02:mgmt-vrf:~$ net add bgp evpn neighbor 172.16.1.9 activate
cumulus@leaf02:mgmt-vrf:~$ net add bgp evpn neighbor 172.16.1.13 activate
cumulus@leaf02:mgmt-vrf:~$ net add bgp evpn advertise-all-vni
cumulus@leaf02:mgmt-vrf:~$ net commit

NOTE: This configuration is only needed on Leaf switches that are VTEPs.

EVPN also supports manual configuration of RDs and RTs, if you don’t want them derived automatically.

To manually define RDs and RTs, use the vni option within NCLU to configure the switch. To build upon the previous example:

#Leaf01cumulus@leaf01:mgmt-vrf:~$ net add bgp evpn neighbor 172.16.1.1 activate
cumulus@leaf01:mgmt-vrf:~$ net add bgp evpn neighbor 172.16.1.5 activate
cumulus@leaf01:mgmt-vrf:~$ net add bgp evpn advertise-all-vni
cumulus@leaf01:mgmt-vrf:~$ net add bgp evpn vni 1014 rd 10.0.1.24:1014
cumulus@leaf01:mgmt-vrf:~$ net add bgp evpn vni 1014 route-target import 65031:1014
cumulus@leaf01:mgmt-vrf:~$ net commit
 #Leaf02cumulus@leaf02:mgmt-vrf:~$ net add bgp evpn neighbor 172.16.1.9 activate
cumulus@leaf02:mgmt-vrf:~$ net add bgp evpn neighbor 172.16.1.13 activate
cumulus@leaf02:mgmt-vrf:~$ net add bgp evpn advertise-all-vni
cumulus@leaf02:mgmt-vrf:~$ net add bgp evpn vni 1014 rd 10.0.1.25:1014
cumulus@leaf02:mgmt-vrf:~$ net add bgp evpn vni 1014 route-target import 65032:1014
cumulus@leaf02:mgmt-vrf:~$ net commit

NOTE: You need to configure “advertise-all-vni” whether you use automatic or user-defined route distinguishers and route targets.

When EVPN is provisioned, data plane MAC learning should be disabled for VxLAN interfaces to avoid race conditions between control plane learning and data plane learning. Configure the bridge-learning value to off:

#Leaf01cumulus@leaf01:mgmt-vrf:~$ net add vxlan vni-1014 bridge learning off
cumulus@leaf01:mgmt-vrf:~$ net commit
#Leaf02cumulus@leaf02:mgmt-vrf:~$ net add vxlan vni-1014 bridge learning off
cumulus@leaf02:mgmt-vrf:~$ net commit

To verify the EVPN configuration, check the network devices participating in BGP/EVPN by using the following command:

cumulus@leaf01:mgmt-vrf:~$ net show bgp evpn summary 
BGP router identifier 10.0.1.24, local AS number 65031 vrf-id 0
BGP table version 0
RIB entries 3, using 432 bytes of memory
Peers 2, using 41 KiB of memory

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
spine01(172.16.1.1) 4 65030 148951 148977 0 0 0 20:21:25 3
spine02(172.16.1.5) 4 65030 148950 148981 0 0 0 20:20:36 3

Total number of neighbors 2
cumulus@leaf01:mgmt-vrf:~$

You can display the configured VNIs on a network device participating in BGP EVPN by running the “show bgp evpn vni” command. This command works only when run on a VTEP (Leaf switch).

cumulus@leaf01:mgmt-vrf:~$ net show bgp evpn vni 
Advertise Gateway Macip: Disabled
Advertise All VNI flag: Enabled
Number of VNIs: 1
Flags: * - Kernel
 VNI Orig IP RD Import RT Export RT 
* 1014 10.0.3.1 10.0.1.24:1 65031:1014 65031:1014 
cumulus@leaf01:mgmt-vrf:~$

TESTING CONNECTIVITY BETWEEN SERVERS

With the Leaf switches announcing their respective VTEP into the underlay BGP routing topology, each Leaf switch learns two equal cost paths (via the Spine switches) to the remote VTEP.

Run the “net show bgp evpn route” command to display all EVPN routes at the same time.

cumulus@leaf01:mgmt-vrf:~$ net show bgp evpn route 
BGP table version is 0, local router ID is 10.0.1.24
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
EVPN type-2 prefix: [2]:[ESI]:[EthTag]:[MAClen]:[MAC]:[IPlen]:[IP]
EVPN type-3 prefix: [3]:[EthTag]:[IPlen]:[OrigIP]

Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 10.0.1.24:1
*> [2]:[0]:[0]:[48]:[52:54:00:e8:a7:59]
 10.0.3.1 32768 i
*> [2]:[0]:[0]:[48]:[52:54:00:e8:a7:59]:[32]:[192.168.14.11]
 10.0.3.1 32768 i
*> [3]:[0]:[32]:[10.0.3.1]
 10.0.3.1 32768 i
Route Distinguisher: 10.0.1.25:1
*> [2]:[0]:[0]:[48]:[52:54:00:60:ad:92]
 10.0.3.2 0 65030 65032 i
* [2]:[0]:[0]:[48]:[52:54:00:60:ad:92]
 10.0.3.2 0 65030 65032 i
* [2]:[0]:[0]:[48]:[52:54:00:60:ad:92]:[32]:[192.168.14.12]
 10.0.3.2 0 65030 65032 i
*> [2]:[0]:[0]:[48]:[52:54:00:60:ad:92]:[32]:[192.168.14.12]
 10.0.3.2 0 65030 65032 i
*> [3]:[0]:[32]:[10.0.3.2]
 10.0.3.2 0 65030 65032 i
* [3]:[0]:[32]:[10.0.3.2]
 10.0.3.2 0 65030 65032 i

Displayed 6 prefixes (9 paths)
cumulus@leaf01:mgmt-vrf:~$

Layer-2 and Layer-3 connectivity between the servers is now possible. Below is the resultant MAC and VXLAN address table for the Leaf switches and the ping results between servers.

server07

server08

Finally, you can examine all local and remote MAC addresses for a VNI by running “net show evpn mac vni” or “net show evpn mac vni all”commands. The Servers MAC addresses must be shown either as local or remote.

cumulus@leaf01:mgmt-vrf:~$ net show evpn mac vni 1014
Number of MACs (local and remote) known for this VNI: 2
MAC Type Intf/Remote VTEP VLAN 
52:54:00:e8:a7:59 local swp1 14 
52:54:00:60:ad:92 remote 10.0.3.2 
cumulus@leaf01:mgmt-vrf:~$
cumulus@leaf02:mgmt-vrf:~$ net show evpn mac vni 1014
Number of MACs (local and remote) known for this VNI: 2
MAC Type Intf/Remote VTEP VLAN 
52:54:00:e8:a7:59 remote 10.0.3.1 
52:54:00:60:ad:92 local swp1 14 
cumulus@leaf02:mgmt-vrf:~$

You can always check my github repository to download the configuration files.

 

Advertisements

Arista Layer-3 Leaf-Spine Fabric with VXLAN HER: Lab Part 4

August 2, 2017
Configuring and Testing VXLAN
by Pablo Narváez

This is the last article in the series, we will finish this lab with the VXLAN configuration and testing connectivity between servers.

VIRTUAL EXTENSIBLE LAN (VXLAN)

The VXLAN protocol is an RFC (7348). The standard defines a MAC in IP encapsulation protocol allowing the construction of Layer-2 domains across a Layer-3 IP infrastructure. The protocol is typically deployed as a data center technology to create overlay networks across a transparent Layer-3 infrastructure:

  • Providing Layer-2 connectivity between racks or PODs without requiring an underlying Layer-2 infrastructure
  • Logical connecting geographically disperse data centers at Layer-2 as a data center Interconnect (DCI) technology
  • VLAN supports up to 16 million virtual overlay tunnels over a physical Layer-2/3 underlay network for Layer-2 network connectivity and multi-tenancy
vxlan-fabric-netwokdiagram

Two-tier Layer-3 VXLAN Ethernet Fabric

VXLAN encapsulation/decapsulation is performed by a VXLAN Tunnel End Point (VTEP), this can be either:

  • A VXLAN-enabled hypervisor such as ESXi, KVM, or XEN (software VTEP)
  • A network switch (hardware VTEP)
Software & Hardware VTEPs

Software & Hardware VTEPs

To create VXLAN overlay virtual networks, IP connectivity is required between VTEPs.

VXLAN CONTROL PLANE

When VXLAN was released, the IETF defined the VXLAN standards (RFC 7348) with a multicast-based flood&learn mechanism that acts as a really complex control plane. It was evident the RFC was incomplete (to say the least) as flooding multicast-based VXLAN in the underlay represented several challenges in the data center including scalability and complexity.

To overcome these limitations, networking vendors started to introduce control plane technologies to replace the multicast-based flooding.

Depending on the vendor, you can have more than one option to deploy a VXLAN control plane solution. To simplify things, it’s a good idea to categorize these technologies:

  1. Network-centric vs Hypervisor-based
  2. Head End Replication vs Dynamic tunnel

Network-centric vs Hypervisor-based solutions

The VXLAN control plane process implies the creation of VXLAN tables that contain the VNI/VLAN mapping information, remote MAC Addresses available per VTEP, and the VTEP/Hypervisor IP Address to establish the VXLAN tunnels.

Some networking vendors have control plane solutions based on SDN that leave the control plane process to an external software layer called Controller. The SDN Controller is responsible for replicating, synchronizing and maintaining the VXLAN tables on the Hypervisors, among other tasks. In order for the Hypervisors to speak with the Controller, VXLAN agents are installed either as part of the host kernel or as a VM inside the Hypervisor on each compute node; the agents (called VTEPs) receive the VXLAN information from the Controller so they can encapsulate/decapsulate traffic based on the instructions contained in the tables.

The use of an SDN Controller as a VXLAN control plane solution is just one option. An alternative is to deploy the VXLAN control plan directly on the Ethernet Fabric. This network-centric solution requires the Ethernet Fabric to be VXLAN-capable meaning the data center switches have to support VXLAN. In the Hypervisor-based solution, the underlay is not aware of the overlay network so the switches do not need to support VXLAN.

NOTE: Since the VXLAN data/control planes are not standardized among vendors, you should expect to find some incompatibility in a multi-vendor network.

Head End Replication vs Dynamic Tunnels Setup

If you want to deploy the VXLAN control plane on the underlay, we need to decide on how to setup the VXLAN tunnels.

VXLAN tunnels can be setup manually (Head End Replication) or dynamically (MP-BGP EVPN). Head End Replication (HER) is the static mappings of VTEPS for the management of broadcast, unicast, multicast, and unknown packets. It requires to configure each switch with the VNI/VLAN mappings and the list of VTEPs to share MAC addresses and forward BUM traffic. This options works well for small and medium-sized networks. However, scalability and human errors are the primary concerns for large networks.

To automate and simplify the VXLAN tunnels setup, Multi-Protocol Border Gateway Protocol Ethernet VPN (MP-BGP EVPN) is used as a routing protocol to coordinate the creation of dynamic tunnels. EVPN is an extension to the MP-BGP address family which allows to carry VXLAN/MAC information in the BGP routing updates.

VXLAN ROUTING AND BRIDGING

The deployment of VXLAN bridging provides Layer-2 connectivity across the Layer-3 Leaf-Spine underlay for hosts. To provide Layer-3 connectivity between the hosts VXLAN routing is required.

VXLAN routing, sometimes referred to as inter-VXLAN routing, provides IP routing between VXLAN VNIs in the overlay network. VXLAN routing involves the routing of traffic based, not on the destination IP address of the outer VXLAN header but the inner header or overlay tenant IP address.

VXLAN Routing Topologies

The introduction of VXLAN routing into the overlay network can be achieved by a direct or indirect routing model:

  • Direct Routing: The direct routing model provides routing at the first-hop Leaf node for all subnets within the overlay network.  This ensures optimal routing of the overlay traffic at the first hop Leaf switch
  • Indirect Routing: To reduce the amount of state (ARP /MAC entries and routes) each Leaf node holds, the Leaf nodes only route for a subset of the subnets

The Direct Routing model works by creating anycast IP addresses for the host subnets across each of the Leaf nodes, providing a logical distributed router. Each Leaf node acts as the default gateway for all the overlay subnets, allowing the VXLAN routing to always occur at the first-hop.

CONFIGURING VXLAN

For this lab, I’m going to use Direct Routing and Head End Replication (HER) to setup the VXLAN tunnel. In later posts, I will add a couple of SDN Controllers to demonstrate the centralized VXLAN control plane option with VXLAN agents on the compute nodes.

NOTE: As of the writing of this article, EVPN is not supported on vEOS. In fact, Arista just announced EVPN support on the latest EOS release, so it’s still a work in progress.

To provide direct routing, the Leaf nodes of the MLAG domain were configured with an IP interface for every subnet. I already covered this part in my previous post: I configured VARP with the “ip virtual router” representing the default gateway for the subnet.

VXLAN Routing with MLAG

On the other hand, Layer-2 connectivity between racks will be achieved by configuring a VXLAN VTEP on the Leaf switches. For the Dual-homed Compute Leaf, a single logical VTEP is required for the MLAG domain. We need to configure the VTEP on both MLAG peers with the same Virtual Tunnel Interface (VTI) IP address, this ensures both peers decapsulate traffic destined to the same IP address.

The logical VTEP in combination with MLAG provides an active-active VXLAN topology.

VXLAN Overlay Networks

VXLAN Overlay Networks

The logical VTEP address is configured as a new loopback interface. This IP address will be used as the VXLAN tunnel source interface.

Let’s configure the Loopback1 interface, we need to configure the same IP address on the MLAG peers.

hostname leaf01
 !
 interface loopback1
 ip address 10.0.2.1/32
 !
hostname leaf02
 !
 interface loopback1
 ip address 10.0.2.1/32
 !
hostname leaf03
 !
 interface loopback1
 ip address 10.0.2.2/32
 !

Next, we need to assign Loopback1 to the VXLAN tunnel interface (VTI).

hostname leaf01
 !
 interface vxlan1
 vxlan source-interface loopback1
 !
hostname leaf02
 !
 interface vxlan1
 vxlan source-interface loopback1
 !
hostname leaf03
 !
 interface vxlan1
 vxlan source-interface loopback1
 !

To map the hosts VLANs to the VNIs, I will use the following mapping:

vlan 11 –> vni 1011
vlan 12 –>
 vni 1012
vlan 13 –>
 vni 1013

hostname leaf01
 !
 interface vxlan1
 vxlan source-interface loopback1
 vxlan vlan11 vni 1011
 vxlan vlan 12 vni 1012
 vxlan vlan 13 vni 1013
 !
hostname leaf02
 !
 interface vxlan1
 vxlan source-interface loopback1
 vxlan vlan11 vni 1011
 vxlan vlan 12 vni 1012
 vxlan vlan 13 vni 1013
 !
hostname leaf03
 !
 interface vxlan1
 vxlan source-interface loopback1
 vxlan vlan11 vni 1011
 vxlan vlan 12 vni 1012
 vxlan vlan 13 vni 1013
 !

Now we have to configure the flood list for the VNIs so the VTEPs can send BUM traffic and learn MAC address between them.

hostname leaf01
 !
 interface vxlan1
 vxlan source-interface loopback1
 vxlan vlan11 vni 1011
 vxlan vlan 12 vni 1012
 vxlan vlan 13 vni 1013
 vxlan vlan11 flood vtep 10.0.2.2
 vxlan vlan12 flood vtep 10.0.2.2
 vxlan vlan13 flood vtep 10.0.2.2
 !
hostname leaf02
 !
 interface vxlan1
 vxlan source-interface loopback1
 vxlan vlan11 vni 1011
 vxlan vlan 12 vni 1012
 vxlan vlan 13 vni 1013
 vxlan vlan11 flood vtep 10.0.2.2
 vxlan vlan12 flood vtep 10.0.2.2
 vxlan vlan13 flood vtep 10.0.2.2
 !
hostname leaf03
 !
 interface vxlan1
 vxlan source-interface loopback1
 vxlan vlan11 vni 1011
 vxlan vlan 12 vni 1012
 vxlan vlan 13 vni 1013
 vxlan vlan11 flood vtep 10.0.2.1
 vxlan vlan12 flood vtep 10.0.2.1
 vxlan vlan13 flood vtep 10.0.2.1
 !

Finally, to provide IP connectivity between the VTEPs, the loopback IP address of the VTIs need to be advertised into BGP. We just need to announce the logical VTEP IP address into BGP when a new VTEP is added to the topology.

hostname leaf01
!
router bgp 65021
network 10.0.2.1/32
!
hostname leaf02
!
router bgp 65021
network 10.0.2.1/32
!
hostname leaf03
!
router bgp 65022
network 10.0.2.2/32
!

With the Leaf switches announcing their respective VTEP into the underlay BGP routing topology, each Leaf switch learns two equal cost paths (via the Spine switches) to the remote VTEP.

Leaf01 show ip route

Leaf02 show ip route

With the direct routing model, the host subnets exist only on the Leaf switches, there is no need to announce them into BGP; the Spine switches are transparent to the overlay subnets, they only learn the VTEP addresses.

Layer-2 and Layer-3 connectivity between the servers is now possible. Below is the resultant MAC and VXLAN address table for the Leaf switches and the ping results between servers.

show Leaf mac-address

show Leaf vxlan-address

ping server01

You can always check my github repository to download the configuration files.

Articles in the series:

 

Arista Layer-3 Leaf-Spine Fabric with VXLAN HER: Lab Part 3

August 2, 2017
Configuring the Layer-3 Ethernet fabric

by Pablo Narváez

Hello there, welcome to the third article in the series. In this post, we will configure the Layer-3 Fabric (Underlay) so we are ready for VXLAN (Overlay).

During the configuration process, you will notice that the Layer-3 Leaf-Spine design (L3LS) design has a number of elements that need to be considered to implement it.

The diagram below shows the fabric we are building, details will be noted and explained in detail the following sections.

Layer3 Ethernet Fabric

Layer3 Ethernet Fabric

For ease of implementation, I’m going to split the configuration in three parts:

  • Management Network: Out-of-band management
  • Layer-2 Configuration: Servers and Leaf switches
  • Layer-3 Configuration: L3LS interconnects and Leaf-Spine routing

Like any network design IP addressing and logical networks need to be allocated and assigned. For the setup, we will use the IP addressing shown below.

IP Address Allocation Table

IP Address Allocation Table

You don’t really need to collect all this information to configure the lab, I just added the MAC addresses and some description to be more organized and to troubleshooting any problem more easily if necessary. However, if you are interested in getting all this information for you home lab, you can access the VM setting on virt-manager and check the details for every VM as described in the previous post.

MANAGEMENT NETWORK

The out-of-band management network provides access and control of the devices outside of the production network. As the name would imply, the primary use of the OOB network is access and control of infrastructure when the production network is unavailable

To configure this network, use the IP Address Allocation Table as a reference. As an example, the configurations for Leaf01 is shown below.

hostname leaf01
!
username admin role network-admin secret xxxxxx
!
vrf definition mgmt
 rd 0:65010
!
interface Management1
 description oob-mgmt
 vrf forwarding mgmt
 ip address 10.0.0.21/24
!
ip routing
!
no ip routing vrf mgmt
!
logging vrf mgmt host 10.0.0.1
!

Note that a VRF (Virtual Routing and Forwarding) is used for management, this will isolate the management network and make it inaccessible outside its subnet (unless you explicitly allow it). From the host machine (base OS), you will be able to ssh/telnet into the switches and servers through this network. Please check the previous article to see the details of the OOB Network.

LAYER-2 CONFIGURATION

As shown in the network diagram above, we have two different Compute Leafs:

  • Dual-homed Server Leaf
  • Single-homed Server Leaf

For the dual-homed server Leaf, our design will consist of a pair of Leaf switches presented to the servers as a single switch through the use of MLAG (Multi-chassis Link Aggregation). One benefit of using MLAG in this particular design is to eliminate the dependence on spanning-tree for loop prevention so all links between Leaf-switches and servers are active. Servers don’t require knowledge of MLAG and can simply be configured with dynamic or static LACP or NIC Bonding.

Layer2 Leaf-Compute Network

Layer-2 Leaf-Compute Network

In regards to the server gateways, this design uses an Anycast default gateway technique known as Virtual Address Resolution Protocol or VARP. On a MLAG pair both switches coordinate the advertisement of an identical MAC and IP address (the VARP address) for the default gateway on each segment. Each default gateway can receive and service the server requests making a first hop intelligent routing decision without traversing the peer link.

MLAG works well with both Virtual Redundant Router Protocol (VRRP) and Virtual ARP (VARP). There are some reasons why I chose VARP over VRRP: Simple configuration.

However, if you were to deploy a virtual gateway technology in production, choosing VARP would make a lot of sense for the following reasons:

  • Reduces the burden on switch CPUs
  • Switches process all traffic requests independently so there’s no unnecessary traffic traversing the peer-link
  • There is no control protocol or messaging bus as utilized in VRRP so switches don’t send control traffic over the peer-link to maintain gateway coordination or to move the control functions from the primary switch to the peer device in case of failure.

For single-homed servers, we don’t need to enable either MLAG or VARP just configure regular access ports and virtual interfaces (SVI).

MLAG Configuration

Server level configuration always needs to be reviewed as well, particularly with dual-homed active/active configurations. If you need help configuring NIC-Bonding/LACP on the servers, please check the following links:

As a rule of thumb, the MLAG group (domain) configuration must be identical on both switches so look carefully at the very few differences between the switches.

MLAG Domain Diagram

MLAG Domain Diagram

The MLAG peer-VLAN 4094 is created and added to the mlagpeer trunk group. The MLAG peers also must have IP reachability with each other over the peer link (SVI for vlan 4094).

hostname leaf01
!
vlan 4094
 name mlag-vlan
 trunk group mlagpeer
!
interface Vlan4094
 description mlag-vlan
 ip address 172.16.254.1/30
!
hostname leaf02
!
vlan 4094
 name mlag-vlan
 trunk group mlagpeer
!
interface Vlan4094
 description mlag-vlan
 ip address 172.16.254.2/30
!

To ensure forwarding between the peers on the peer link, spanning-tree must also be disabled on this vlan. Once the port channel is created for the peer link and configured as a trunk port on Ethernet6 and Ethernet7, additional VLANs may be added if necessary to transit the peer link. In this example, I’m configuring vlan 11 for server01, adding this vlan to the port channel, and configuring the server-facing ports (Ethernet1 on both switches).

hostname leaf01
!
no spanning-tree vlan 4094
!
interface Port-Channel11
 description service01-portchannel
 switchport trunk allowed vlan 11
 switchport mode trunk
 mlag 11
!
interface Port-Channel54
 description mlag-portchannel
 switchport mode trunk
 switchport trunk group mlagpeer
!
interface Ethernet1
description server01-ens2
channel-group 11 mode active
!
interface Ethernet6
description link_to_leaf02-eth6 (mlag-peerlink1)
channel-group 54 mode active
!
interface Ethernet7
 description link_to_leaf02-eth7 (mlag-peerlink2)
 channel-group 54 mode active
!

Next, we need to configure the actual MLAG domain which must be unique for each MLAG pair. As part of the domain configuration, we are using interface vlan 4094 for IP reachability and Port-Channel 54 as the physical peer link.

hostname leaf01
!
mlag configuration
 domain-id mlagDomain
 local-interface Vlan 4094
 peer-address 172.16.254.2
 peer-link Port-Channel54
 reload-delay 500
!
hostname leaf02
!
mlag configuration
 domain-id mlagDomain
 local-interface Vlan 4094
 peer-address 172.16.254.1
 peer-link Port-Channel54
 reload-delay 500
!

MLAG Verification

To verify the MLAG operation, you can run the following commands:

  • show mlag
  • show mlag config-sanity

Make sure the peer configuration is consistent and the MLAG status is Active. If you see a different MLAG state or any other error in the output check the MLAG troubleshooting guide posted here.

For single-homed servers, ports are configured as access ports and assigned a VLAN. A Switched Virtual Interface (SVI) is created for each VLAN, which acts as the default gateway for the host/workload.

VARP Configuration

Leaf01 and Leaf02 are MLAG peers and are configured to run VARP to provide an active/active redundant first hop gateway for server01 and server04. To provide routing within each rack, the Leaf nodes of an MLAG domain must be configured with an IP interface in every subnet.

hostname leaf01
!
int vlan 11
 description service01-gateway
 ip add 192.168.11.2/24
 ip virtual-router address 192.168.11.1
!
ip virtual-router mac-address 001c.aaaa.aaaa
!
hostname leaf02
!
int vlan 11
 description service01-gateway
 ip add 192.168.11.3/24
 ip virtual-router address 192.168.11.1
!
ip virtual-router mac-address 001c.aaaa.aaaa
!

The global common virtual MAC address is unique for each MLAG domain. In this example, the default gateway for vlan 11 uses 192.168.11.1 which is resolved into the virtual MAC address 001c.aaaa.aaaa.

NOTE: As stated above, there’s no need to configure MLAG/VARP on Leaf03.

Repeat the same steps to configure the remaining VLANs (vlans 11-12).  When this is done, you must be able to reach the default gateway IP addresses from the servers assuming everything is configured correctly on the server side.

LAYER-3 CONFIGURATION

Leaf-Spine Interconnects

All Leaf switches are directly connected to all spine switches. In a L3LS topology all of these interconnections are routed links. These routed interconnects can be designed as point-to-point links or as port channels. For production environments, there are pros and cons to each design, Leaf-Spine interconnects require careful consideration to ensure uplinks are not over-subscribed. Point-to-point routed links will be the focus of this guide.

Point-to-Point Routed Interfaces

Point-to-Point Routed Interfaces

As you can see, each Leaf has a point- to-point network between itself and each Spine. In real-life environments, you need to strike the right balance between address conservation and leaving room for the unknown. Using a /31 mask will work as will a /30, the decision will depend on your personal circumstances.

Check the configuration for Leaf01, then you can configure the remaining switches as described in the IP Address Allocation Table.

# leaf01
...
interface Ethernet1
 description server01-ens2
 switchport access vlan 11
!
interface Ethernet2
 description server02-ens2
!
interface Ethernet3
 description server03-ens2
!
interface Ethernet4
 description link_to_spine01-eth1
 no switchport
 ip address 172.16.0.2/30
!
interface Ethernet5
 description link_to_spine02-eth1
 no switchport
 ip address 172.16.0.14/30
!
interface Ethernet6
 description link_to_leaf02-eth6 (mlag-peerlink1)
 channel-group 54 mode on
!
interface Ethernet7
 description link_to_leaf02-eth7 (mlag-peerlink2)
 channel-group 54 mode on
!
interface Loopback0
 description router-id
 ip address 10.0.1.21/32
!
....
!
ip routing
no ip routing vrf mgmt
!

Border Gateway Protocol (BGP) Design

Leaf and Spine switches are interconnected with Layer-3 point-to-point links, and every Leaf is connected to all Spines with at least one interface. Also, there’s no direct dependency or interconnection between Spine switches. All the Leaf nodes can send traffic evenly towards the Spine through the use of Equal Cost Multi Path (ECMP) which is inherent to the use of routing technologies in the design.

NOTE: We have just two Spine switches in our lab, but you can add additional nodes on demand. It’s not required to have an even number of Spine switches, just make sure to have at least one link from each Leaf to every Spine.

Even though you can use OSPF, IS-IS or BGP as the fabric routing protocol, BGP has become the routing protocol of choice for large data centers. Some of the reasons to choose BGP over its alternatives are:

  • Extensive Multi-Vendor interoperability
  • Native Traffic Engineering (TE) capabilities
  • Minimized information flooding, when compared to link-state protocols
  • Reliance on TCP rather than adjacency forming
  • Reduced complexity and simplified troubleshooting
  • Mature and proven stability at scale

As you may know, we have two options to deploy BGP as the fabric routing protocol: eBGP vs iBGP. There are pros and cons for each of them…

eBGP vs. iBGP

There are number of reasons to choose eBGP but one of the more compelling reasons is simplicity, particularly when configuring load sharing (via ECMP) which is one of the main design goals of the L3LS. Using eBGP ensures all routes/paths are utilized with the least amount of complexity and fewest steps to configure.

I’ve tested both options and my personal choice is eBGP even on production environments. Although an iBGP implementation is technically feasible using eBGP allows for a simpler less complex design that is easier to troubleshoot.

NOTE: When integrating a MLAG Leaf configuration into a Layer-3 Leaf-Spine, iBGP peering is recommend between the MLAG peers. The reason for the peering is due to specific failure conditions that the design must take into consideration, this will be explained in detail in the next section.

BGP Autonomous System Number (ASN)

BGP supports several designs when assigning Autonomous System Numbers (ASN) in a L3LS topology. For this lab, the Common Spine ASN – Discrete Leaf ASN design will be used.

This design uses a single ASN for all spine nodes and discrete ASNs for each leaf nodes. Some benefits of this design are:

  • Each rack can now be identified by its ASN
  • Traceroute and bgp commands will show discrete AS making troubleshooting easier
  • Uses inherent BGP loop prevention
  • Unique AS numbers help troubleshooting and don’t require flexing the EBGP path selection algorithm

As an alternative, you can use the Common Spine ASN – Common Leaf ASN design where a common (shared) ASN will be assigned to the Spine nodes and another ASN to the Leaf nodes. If you want to try this option, please check the configuration guide posted here.

BGP Configuration

For the Spine configuration the default BGP distance is altered to give preference to external BGP routes (this might not be necessary for the lab, but keep it in mind when deploying this configuration in production environments). Leaf neighbors are also defined and utilize a peer-group to simplify configuration.

Note that all spine switches share a common ASN while each Leaf-pair has a different ASN, see the BGP diagram below for details.

bgp_asn_scheme-1

BGP ASN Scheme

NOTE: This guide will use the private AS numbers between 64512 through 65535.

Loopback interfaces will be used as the router-id on each switch, so we are configuring a Loopback0 interface with a /30 mask for every switch.

Follow this table below to configure the loopback interfaces.

Loopback IP Address Allocation Table

Loopback IP Address Allocation Table

To start, let’s see the  Spine switches configuration.

hostname spine01
!
router bgp 65020
 router-id 10.0.1.11
 bgp log-neighbor-changes
 distance bgp 20 200 200
 maximum-paths 2 ecmp 64
 neighbor 172.16.0.2 remote-as 65021
 neighbor 172.16.0.6 remote-as 65021
 neighbor 172.16.0.10 remote-as 65022
 network 10.0.1.11/32
!
hostname spine02
!
router bgp 65020
 router-id 10.0.1.12
 bgp log-neighbor-changes
 distance bgp 20 200 200
 maximum-paths 2 ecmp 64
 neighbor 172.16.0.14 remote-as 65021
 neighbor 172.16.0.18 remote-as 65021
 neighbor 172.16.0.22 remote-as 65022
 network 10.0.1.12/32
!

This example uses static BGP peer groups. When a static peer group is created, the group name can be used to apply the configuration to all members of the group.

The Leaf switch configuration is very similar to the Spine, a single peer-group is utilized to peer with the spine with a standard configuration.

hostname leaf01
!
router bgp 65021
 router-id 10.0.1.21
 bgp log-neighbor-changes
 distance bgp 20 200 200
 maximum-paths 2 ecmp 2
 neighbor ebgp-to-spine-peers peer-group
 neighbor ebgp-to-spine-peers remote-as 65020
 neighbor ebgp-to-spine-peers maximum-routes 12000
 neighbor 172.16.0.1 peer-group ebgp-to-spine-peers
 neighbor 172.16.0.13 peer-group ebgp-to-spine-peers
 neighbor 172.16.254.2 remote-as 65021
 neighbor 172.16.254.2 next-hop-self
 neighbor 172.16.254.2 maximum-routes 12000
 network 10.0.1.21/32
 redistributed connected
!
hostname leaf02
!
router bgp 65021
 router-id 10.0.1.22
 bgp log-neighbor-changes
 distance bgp 20 200 200
 maximum-paths 2 ecmp 2
 neighbor ebgp-to-spine-peers peer-group
 neighbor ebgp-to-spine-peers remote-as 65020
 neighbor ebgp-to-spine-peers maximum-routes 12000 
 neighbor 172.16.0.5 peer-group ebgp-to-spine-peers
 neighbor 172.16.0.17 peer-group ebgp-to-spine-peers
 neighbor 172.16.254.1 remote-as 65021
 neighbor 172.16.254.1 next-hop-self
 neighbor 172.16.254.1 maximum-routes 12000
 network 10.0.1.22/32
 redistributed connected
!

NOTE: The “redistribute connected” command will redistribute all the directly connected interfaces into BGP for connectivity testing purposes. In production, link addresses are not typically advertised. This is because:

  • Link addresses take up valuable FIB resources. In a large CLOS (Leaf-Spine) environment, the number of such addresses can be quite large
  • Link addresses expose an additional attack vector for intruders to use to either break in or engage in DDOS attacks

When we have an MLAG domain as part of a Layer-3 fabric, iBGP peering is recommend between the MLAG peers. The reason for the peering is due to specific failure conditions that the design must take into consideration; such failures include the Leaf-Spine uplinks, routes learned via iBGP will come into effect if all uplinks fail.

Let’s say all Leaf01 uplinks fail, with an iBGP peering between Leaf01 and Leaf02 any server traffic forwarded to Leaf01 would follow the remaining route pointing to Leaf02 and then be ECMP-routed to the Spine.

NOTE: In normal operation paths learned via eBGP (Leaf to Spine uplinks) will always be preferred over paths learned via iBGP (MLAG peers).

The neighbor next-hop-self command configures the switch to list its address as the next hop in routes that it advertises to the specified BGP-speaking neighbor or neighbors in the specified peer group. This is used in networks where BGP neighbors do not directly access all other neighbors on the same subnet.

Route Advertising

In production environments, you need to ensure that only the proper routes are advertised from Leaf switches, so a route map must be applied to the Spine BGP-peers. The route map references the prefix-list which contains the routes that are intended to be advertised to the Spine.

Although not mandatory, using a route map or a prefix list provides a level of protection in the network. Without a route map random networks could be created at the Leaf, which would automatically be added to the routing table.

BGP Verification

You can verify the BGP operation by running the following commands:

  • show ip bgp summary
  • show ip route

The state for all neighbors should be ESTABLISHED.

Since the server VLANs will be encapsulated in VXLAN between VTEPs, we don’t need to advertise them into BGP so I’m going to filter networks 192.168.11.0/24, 192.168.12.0/24, 192.168.13.0/24 out of the Leaf.

# leaf01 and leaf02
ip prefix-list filter-out-to-spine seq 10 deny 192.168.11.0/24
ip prefix-list filter-out-to-spine seq 20 deny 192.168.12.0/24
ip prefix-list filter-out-to-spine seq 20 deny 192.168.13.0/24 
ip prefix-list filter-out-to-spine seq 30 permit 0.0.0.0/0 le 32
!
router bgp 65021
   neighbor ebgp-to-spine-peers prefix-list filter-out-to-spine out

# leaf03
ip prefix-list filter-out-to-spine seq 10 deny 192.168.11.0/24
ip prefix-list filter-out-to-spine seq 20 deny 192.168.12.0/24
ip prefix-list filter-out-to-spine seq 20 deny 192.168.13.0/24 
ip prefix-list filter-out-to-spine seq 30 permit 0.0.0.0/0 le 32
!
router bgp 65022
   neighbor ebgp-to-spine-peers prefix-list filter-out-to-spine out

Once the filter-list is applied on the Leaf switches, the output of “show ip route” on the Spine should display the loopback interfaces and point-to-point links but no server networks must be shown.

spine01#show ip route
VRF name: default
Codes: C - connected, S - static, K - kernel,
 O - OSPF, IA - OSPF inter area, E1 - OSPF external type 1,
 E2 - OSPF external type 2, N1 - OSPF NSSA external type 1,
 N2 - OSPF NSSA external type2, B I - iBGP, B E - eBGP,
 R - RIP, I L1 - ISIS level 1, I L2 - ISIS level 2,
 O3 - OSPFv3, A B - BGP Aggregate, A O - OSPF Summary,
 NG - Nexthop Group Static Route, V - VXLAN Control Service

Gateway of last resort is not set

B E 10.0.1.1/32 [20/0] via 172.16.0.25, Ethernet4 
                       via 172.16.0.33, Ethernet5
 B E 10.0.1.2/32 [20/0] via 172.16.0.25, Ethernet4 
                        via 172.16.0.33, Ethernet5
 C 10.0.1.11/32 is directly connected, Loopback0 
B E 10.0.1.21/32 [20/0] via 172.16.0.2, Ethernet1
                        via 172.16.0.6, Ethernet2 
B E 10.0.1.22/32 [20/0] via 172.16.0.2, Ethernet1
                        via 172.16.0.6, Ethernet2
 B E 10.0.1.23/32 [20/0] via 172.16.0.10, Ethernet3
 B E 10.0.2.1/32 [20/0] via 172.16.0.2, Ethernet1
                        via 172.16.0.6, Ethernet2
 B E 10.0.2.2/32 [20/0] via 172.16.0.10, Ethernet3
 C 172.16.0.0/30 is directly connected, Ethernet1
 C 172.16.0.4/30 is directly connected, Ethernet2
 C 172.16.0.8/30 is directly connected, Ethernet3
 B E 172.16.0.12/30 [20/0] via 172.16.0.2, Ethernet1
                           via 172.16.0.6, Ethernet2
 B E 172.16.0.16/30 [20/0] via 172.16.0.2, Ethernet1
                           via 172.16.0.6, Ethernet2
 B E 172.16.0.20/30 [20/0] via 172.16.0.10, Ethernet3
 C 172.16.0.24/30 is directly connected, Ethernet4
 C 172.16.0.32/30 is directly connected, Ethernet5
 B E 172.16.254.0/30 [20/0] via 172.16.0.2, Ethernet1
                            via 172.16.0.6, Ethernet2

There you go! The Underlay (L3SL Fabric) is up and running. In the next post, we will configure and test VXLAN.

You can always check my github repository to download the configuration files.

Articles in the series:

Arista Layer-3 Leaf-Spine Fabric with VXLAN HER: Lab Part 2

July 19, 2017
Virtual Environment Setup
by Pablo Narváez

Welcome to the second blog post in my multi-part series describing in detail how I will deploy a L3SL-V Ethernet fabric with Arista vEOS and Ubuntu/KVM. In this post, I’m going to dive into the first component of the deployment: the virtual environment and the VMs.

vm_spreadsheet3

Virtual Machine Spreadsheet – Inventory List

As it’s shown in the inventory list above (spreadsheet), I’m going to use a single server with KVM to create multiple VMs. I’ll go with Ubuntu Desktop for the server OS, but you can choose the Server version (Since Ubuntu 12.04, there is no difference in kernel between Ubuntu Desktop and Ubuntu Server).

This guide assumes you have a Linux user graphical interface, so the Desktop version is desired.

To download and install Ubuntu, please follow these links:

NOTE: I chose a Type 2 hypervisor (run on a host OS) over bare-metal to have a flexible environment: for this kind of setups I prefer to have a base OS in order to use some traffic monitoring tools (like Wireshark) and to have a centralized repository for software images.

In addition to that, I chose KVM over VirtualBox because of the number of NIC cards (vNICs) supported: VirtualBox only supports 8 network adapters per VM. Since I will be using this lab to deploy some other unplanned functionalities, I just didn’t want to end up with such limitations in case I need to add additional vNICs.

If you want to give VirtualBox a try, you can follow these links:

KVM INSTALLATION

The procedure described below is a summary of the official guide posted here.

Pre-Installation Checklist

To run KVM, you need a processor that supports hardware virtualization. To see if your processor supports it, you need to install cpu-checker:

$ sudo apt-get install cpu-checker

Now, you can review the output from this command:

$ kvm-ok

which may provide an output like this:

INFO: /dev/kvm exists
KVM acceleration can be used

If this is your case, you are good to go.

If you see :

INFO: Your CPU does not support KVM extensions
KVM acceleration can NOT be used

You can still run virtual machines, but it’ll be much slower without the KVM extensions.

NOTE: Running a 64 bit kernel on the host operating system is recommended but not required. On a 32-bit kernel install, you’ll be limited to 2GB RAM at maximum for a given VM.

Installation of KVM

You need to install a few packages first:

$ sudo apt-get install qemu-kvm libvirt-bin ubuntu-vm-builder bridge-utils virt-viewer virt-manager
  •  qemu-kvm(kvmin Karmic and earlier) is the backend
  • libvirt-binprovides libvirtd which you need to administer qemu and kvm instances using libvirt
  • ubuntu-vm-builderis a powerful command line tool for building virtual machines
  • bridge-utilsprovides a bridge from your network to the virtual machines. This package is optional, but highly recommended in case you have multiple network adapters on the host and want to map some VMs to an external network. Another option is Open vSwitch as a replacement for the Linux Bridge.
  • virt-viewer is a tool for viewing instances. This package is optional, but strongly recommended to display a graphical console for VMs
  • virt-manager is GUI tool to manage virtual machines. This module is optional, but strongly recommended to simplify the VM life-cycle management. If not installed, you will have to manage VMs with the Virsh command-line

After the installation, you need to relogin so that your user becomes an effective member of KVM and libvirtd user groups. Only the members of this group can run virtual machines.

Verify the Installation

After you relogin, test if your installation has been completed successfully with the following command:

$ virsh list --all
 Id Name                 State
----------------------------------
$

If you get something like this:

$ virsh list --all
libvir: Remote error : Permission denied
error: failed to connect to the hypervisor
$

Something is wrong (e.g. you did not relogin) and you probably want to fix this before you move on.

To troubleshoot any issues during or after the installation, please check the official KVM installation guide posted here.

VM VIRTUAL NETWORKING

This is what we are going to build.

vm_network_diagram2

Virtual Machine Network Diagram

The drawing shows where each network adapter (vNIC) is, what network it’s configured for, and how the VMs are interconnected. Every connection between two adapters represents an isolated segment which must be configured as a virtual network in KVM.

To ensure that every link is isolated, we need to configure each virtual network with an exclusive name (I configured them as “net-x”), disable IP routing, and use every virtual network only once for a unique link.

The links between each VM will act like physical cables, but the virtual network connecting the management interfaces of the Ubuntu Linux servers and the Arista switches are on a common shared network (“net-oob”). The host will also have an adapter connected to this network so we can ssh into each device through the Out-of-Band management interface (OOB).

vm_oob-management_diagram

Virtual Machine Out-of-Band Management Network Diagram

The first network adapter will always end up being the Management1 interface in each switch. To simplify things, I dedicated the first network adapter (vNIC1) for management on each VM.

CREATING VMs

We will have two different types of VMs: Ubuntu servers an Arista switches. For Linux, we are going to install the same software image that we used for the host OS. For the Arista switches, there are two files that are needed: the virtual hard drive (vmdk) and the Aboot ISO file.

You need to register at arista.com to download the software. Once you login, go to Support > Software Download to retrieve the following files:

vEOS-lab-4.17.5M.vmdk
Aboot-veos-8.0.0.iso

NOTE: There are several folders and more than one image format, make sure to download the correct files from the vEOS-lab folder.

To build the VMs faster, we are going to create two base VMs (golden images, one for the servers and one for the switches), then clone them multiple times.

Creating the Base VM for Servers

The easiest way to create a virtual machine in KVM is to use the Virtual Machine Manager application. You can find it in your applications dashboard.

virt-manager_dashboard

Or you can use the command-line:

$ virt-manager

virt-manager_cli

The first thing to do is create the virtual networks for the network adapters. Look at the network drawing and the spreadsheet at the beginning of this section.

In the virt-manager main window, click the edit button on the toolbar, then click on Connection Details.

virt-manager_menu

Go into the Virtual Networks tab, click the add button (“+” icon, lower left corner).

Give the network a name. This is going to be our first virtual network, so we will start with “net-1”.

virt-manager_network

We will simulate physical network connections so we don’t need to assign IP addresses for now.

NOTE: When creating the out-of-band management network (“net-oob“) you might want to enable the IP address definition so KVM adds a virtual network adapter on the host to communicate directly with the VMs (for ssh/admin purposes).

Uncheck the Enable IPv4 network address space definition option, do the same for IPv6 in the next step.

virt-manager_ipv4

We need isolated segments to interconnect the VMs, so choose the isolated virtual network option and then click the finish button to continue.

virt-manager_isolated-net

Repeat the same steps to create the rest of the networks. Don’t forget to add the management network (“net-oob”).

NOTE: Enable the IP address space when creating “net-oob” for management. In this case, I will be using 10.0.0.0/24 for the network and the host will receive the IP address 10.0.0.1/24.

When this done, there must be a total of 18 networks (net-1 thru net-17, plus net-oob).

virt-manager_virt-nets

Now we need to create the actual VMs. Go back into the virt-manager main screen and click the Create New Virtual Machine icon on the toolbar to start the installation.

First, set the virtual machine’s name (“server01”) and select the installation method, select Local install media (ISO image or CDROM).

Next, we need to find and select the Linux image (Ubuntu 16.04.2 ISO file). Make sure to check the Automatically detect the operating system option.

virt-manager_media

You should now choose how much memory to allocate for the VM. Allocate 2040MB of memory and 1 CPU.

Remember: To allocate more than 2GB of memory to a virtual machine, you need to have a 64-bit CPU and a 64-bit Linux kernel.

Check the Enable storage for this virtual machine option and allocate the disk space for the vm. In my case, I will leave the default space (20 GB).

By default, KVM configures NAT for the network adapters. We need to configure the network adapters on each VM as shown in the spreadsheet.

To do so, before clicking on the Finish button, make sure to check the Customize configuration before install option to edit the VM settings.

NOTE: You can always customize the VM configuration after the installation.

virt-manager_customize

Now we need to configure all of the internal networks within the VMs, I’ll show some examples.

From the left hand side menu, click on the only NIC adapter available and open the Netwok Source drop-down menu. You will see all the virtual networks we created in the previuos steps.

virt-manager_net-menu

From the drop-down menu, choose Virtual Network net-oob” to assign the management network to the adapter and configure “e1000” for Device model.

Remember: The first NIC on all VMS will always be the management interface.

virt-manager_nic1

Then, click on the Add Hardware button (lower left corner) and add two NIC adapters for “net-1” and “net-2” respectively. Don’t forget to choose “e1000” for the Device model option.

virt-manager_nic2

You can click on the Begin Installation button on the upper left corner to start the OS installation.

virt-manager_os-instpng

Virt-manager will boot the guest operating system, you may now proceed to install the OS.

Cloning the Base VM (Ubuntu Servers)  

Now we need to clone the base VM to build the rest of the servers. The main virt-manager window will show server01, right click on it and click Clone.

NOTE: You need to power off the VM to clone it.

virt-manager_clone

In the clone window, change the server name (“server02”, in this case), leave the default settings for Networking and make sure to choose the Clone this disk option for the disk storage.

virt-manager_clone-conf

Click on the Clone button to finish. Repeat the same steps to create the rest of the servers.

Finally, we need to configure the network settings for each adapter on every server (remember, every cloned VM will have server01 settings so we need to change that).

I will show you one example: In the virt-manager main window, right click on server02 and click Open.

virt-manager_clone-menu

Within the configuration menu, click on the second NIC adapter and choose “net-3” from the Netwok source drop-down menu; then, assign “net-4” to the third NIC.

virt-manager_clone-nics

Configure the remaining network adapters on each VM as shown in the spreadsheet.

Creating the Fabric Switches

Not quite done yet! We need to build the VMs to run Arista vEOS. The process will be quite different and we will have to tweak some settings to make the vEOS boot, so stick with me.

In the virt-manager main window, click on the Create a new virtual machine and select the last option: Import existing disk image.

Browse and locate the vEOS-lb-4.17.5M.vmdk file in your server, leave the default setting for OS Type and Version.

virt-manager_veos-os

Next, allocate 2048MB of memory and 1 CPU.

NOTE: With the latest vEOS release it is now required to allocate at least 2GB of memory.

Before clicking on the Finish button, name the VM (“spine01”) and make sure to check the Customize configuration before install option.

It’s time to tweak some settings before installing the OS. First, take a look at the screen below, this is what you should have by now.

virt-manager_veos-conf

While in this window, modify the following:

  1. Remove the IDE Disk 1 – I know, I know, it’s the disk we just created a few steps back with the vmdk file, but it’s critical to build the disks from scratch
  2. Remove the sound controller (Sound: ich 6 in my case)
  3. Change the video settings from QXL to VGA
  4. Change the NIC configuration – Choose the “net-oob” virtual network for management and configure “e1000” for the Device model option.
  5. Add three additional NICs for “vnet-11”, “vnet-13” and “vnet-15” respectively,  choose “e1000” for Device model.
  6. Add two disk storage devices, one IDE disk with the vmdk file and one IDE CD device with the Aboot.iso file (see below).

virt-manager_veos-disks

Arista vEOS is very particular about how its storage is configured. Both drives need to be IDE and the Aboot.iso (boot-loader) needs to be installed as a CD. If a SCSI controller gets created, it must be deleted or vEOS will not load.

virt-manager_veos-cdrom

Next, we need to make the VM boot from the CD to load the Aboot.iso file. Change the Boot Options to boot from the IDE CDROM 1.

virt-manager_veos-bootseq

Click Apply to close the window. Go ahead and click on the Begin Installation button, you will see the boot-loader run.

virt-manager_veos-bootload

If you have ever installed vEOS on other hypervisors, you will notice that it takes too long to boot in KVM with the same resources allocated. In addition to that, it’s important to be aware that you will not see the booting sequence, be patient and wait for the command-line to appear!

virt-manager_veos-cli

¡Listo! The base VM is ready. Clone the VM so you can create spine02, leaf01, leaf02 and leaf03.

Don’t forget to customize the network configuration for each VM, configure the network adapters as shown in the spreadsheet.

VERIFY THE INSTALLATION

You should see all the VMs on the virt-manager main window. Run all the VMs and wait until they are operational.

virt-manager_all-vms

You can also test if your installation has been completed successfully with the following command:

$ virsh list --all

All VMs must be in the running state and you should be able to access the user interface on each VM.

virsh_all-vms

When this is done, the lab should be bootable and every device should be connected to every other device according to the original network diagram.

In the next post, we will configure the L2/L3 protocols for the fabric, stay tuned!

You can always check my github repository to download the configuration files.

Articles in the series:

 

Arista Layer-3 Leaf-Spine Fabric with VXLAN HER: Lab Part 1

July 11, 2017
Introduction
by Pablo Narváez

This is the first post in a series where I’ll go deep on how VXLAN is deployed on Arista switches and how it operates in a Layer-3 Ethernet fabric.

vxlan-fabric-netwokdiagram

Two-tier Layer-3 VXLAN Ethernet Fabric

For this lab, I will create a self-contained virtual environment with Ubuntu Linux/KVM and Arista virtual EOS (vEOS). Please note, the IP Storage, Services and Border Leafs will not be deployed yet; once we are done with VXLAN, I will add new features and functionalities including the extra Leafs.

Hardware and versions to be used in my lab:

• 2x HPE DL-360 ProLiant Gen8 server
– 2x 64bit 8-core Intel Xeon processors (E5-2650)
– 128GB RAM
– 4x 300GB SAS drives (sda, RAID 0)
– 2x 1TB SAS drivers (sdb, RAID 0)
– 1x iLO dedicated GE network port
– 4x embedded GE network ports
– 1x 10GbE dual-port network module
• Ubuntu 16.04.2 LTS with KVM
• VMware iESXi 6.5
• Arista vEOS 4.17.5M

I will provide detailed instructions for what to do (and configure) on every device. Equipment and operating systems versions may change along the way, so I will make appropriate notes wherever needed.

This was just an overview of the virtual lab I will be building. As stated before, I am going to follow this up with a series of articles focusing on the different infrastructure layers; as those articles are released, the links will be updated here:

You can always check my github repository to download the configuration files.